Skip to main content
Skip table of contents

Updateanleitungen

Bitte wählen Sie die passende Anleitung entsprechend der von Ihnen für die ForumSuite genutzten technischen Plattform.

Unsere Produkte ForumISM, ForumBCM, ForumDSM, ForumOSM und ForumNSR sind Teil der ForumSuite. Durch ein Update kommt es zu technischen Änderungen in allen Anwendungen.

Weisen Sie bitte alle verantwortlichen Personen auf diese Informationen hin und stimmen Sie das Update mit den Fachabteilungen entsprechend ab.


Aktualisierung der Java Runtime

Die folgenden Tätigkeiten müssen alle auf dem Server der ForumSuite ausgeführt werden.

Betriebssystem Windows

Prüfung IST Zustand

  1. Öffnen Sie bitte im Windows Explorer  den Installationspfad der ForumSuite
  2. Bearbeiten Sie bitte die Datei start_suite.cmd

    Abbildung: Edit start_suite.cmd
  3. Prüfen Sie bitte nun den Pfad für den Aufruf der Laufzeitumgebung

    Abbildung 1: in ForumSuite Ordner eingebettete Java Runtime

    Abbildung 2: Java Runtime des Betriebssystems

    In diesem Fall fragen Sie die eingesetzte Version bitte über die Eingabeaufforderung mittels des Befehls java -version  ab.

    Abbildung 2.1: Abfrage Version der installierten Java Runtime


Sollten Sie mit einer installierten Java Runtime arbeiten (Abbildung 2), prüfen Sie bitte, ob noch andere Anwendungen diese Runtime nutzen/voraussetzen.
Falls ja, erfragen Sie bitte beim Hersteller, ob die Anwendung mit einer Java Runtime 17*  betrieben werden kann.

Update Java Runtime - Abbildung 1 (eingebettete Java Runtime)

  1. Laden Sie die portable Version 17 der Java Runtime von ADOPTIUM herunter (
    )
  2. Entpacken Sie den Inhalt des Archivs
  3. Kopieren Sie den Ordner jdk-17*-jre in den Ordner der ForumSuite
  4. Stoppen Sie den Dienst der ForumSuite
  5. Bearbeiten Sie bitte die Datei start_suite.cmd

    Abbildung: Edit start_suite.cmd
  6. start_suite.cmd - vorher

    BASH
    FOR %%f IN (FORUM_Suite_*.jar) DO .\jdk-11.0.17+8-jre\bin\java -Djavax.net.ssl.trustStoreType=WINDOWS-ROOT -Xmx8G -jar %%f

    start_suite.cmd - nachher (Beispiel)

    BASH
    #Bitte den String jdk-17... entsprechend anpassen
    FOR %%f IN (FORUM_Suite_*.jar) DO .\jdk-17.N.N.N+N-jre\bin\java -Djavax.net.ssl.trustStoreType=WINDOWS-ROOT -Xmx8G -jar %%f
  7. Speichern und schließen Sie die Datei start_suite.cmd 
  8. Starten Sie den Dienst der ForumSuite

Update Java Runtime - Abbildung 2 (Java Runtime des Betriebssystems)

  1. Laden Sie die installierbare Version 17 der Java Runtime von ADOPTIUM herunter (
    )
  2. Stoppen Sie den Dienst der ForumSuite
  3. Deinstallieren Sie die Java 11 Runtime via Systemsteuerung\Alle Systemsteuerungselemente\Programme und Features 
  4. Installieren Sie das Paket inkl. der Optionen JAVA_HOME  und JavaSoft (Oracle) 

    Abbildung: Installationsparamter
  5. Prüfung der Version über die Eingabeaufforderung mittels des Befehls java -version .
    Ergebnis sollte nun Version 17* sein.
  6. Starten Sie den Dienst der ForumSuite
Betriebssystem Linux

Nachfolgend wir die Aktualisierung unter Linux (hier: Debian Bullseye ) beschrieben.
Es wird davon ausgegangen, das die ForumSuite im systemd eingebunden ist

  1. ForumSuite stoppen

    BASH
    systemctl stop forumsuite.service
  2. Java 11 deinstallieren

    BASH
    apt remove openjdk-11-jre
    apt update;apt upgrade;apt autoremove;apt autoclean
  3. Java 17 installieren

    BASH
    apt install openjdk-17-jre
  4. ForumSuite starten

    BASH
    systemctl start forumsuite.service


Aktualisierung der Vorschläge / Kataloge

Für die Produkte aus dem Compliance-Bereich (ForumCMS, ForumNMS, ForumTCM und ForumWPC) gilt unabhängig von der Plattform die Anleitung der Java Version.

HCL Domino

In der nachfolgenden Anleitung werden die folgenden Platzhalter verwendet:

  • <app> .. Platzhalter für das Kürzel der betroffenen Anwendung
  • <x.y.z.> .. Platzhalter für die aktuelle Versionsnummer
  • <katalog> .. Platzhalter für Katalogbezeichnung
  • <JJJJ>-<MM> .. Platzhalter für Jahr und Monat
  1. Kopieren der Datenbank auf den Server

    Entpacken Sie das Updatearchiv für die Forum<APP> Vorschläge in ein lokales Verzeichnis. Kopieren Sie danach die Datenbank <app>_vorschlaege_<JJJJ>-<MM>.nsf/<app>_katalog_<katalog>_<JJJJ>-<MM>.nsf in das lokale Datenverzeichnis Ihres IBM Notes Clients.
    Erstellen Sie anschließend über die Notes Funktion Anwendung > Neue Kopie eine Kopie der Datenbank <app>_vorschlaege_<JJJJ>-<MM>.nsf/<app>_katalog_<katalog>_<JJJJ>-<MM>.nsf auf Ihrem Domino Server.

    Übertragen Sie die Datenbank nicht direkt über das Dateisystem auf den Domino Server, da diese hierbei beschädigt werden kann.

    Signieren Sie die Anwendung <app>_vorschlaege_<JJJJ>-<MM>.nsf/<app>_katalog_<katalog>_<JJJJ>-<MM>.nsf mit einer vertrauenswürdigen Notes-ID. Hierzu wird entweder die ID eines speziellen Freigabe-Nutzers, eines Administrators oder die ID des Servers genutzt.

  2. Zugriffskontrollliste Forum<APP> Vorschläge anpassen

    Passen Sie die Zugriffskontrollliste (ACL) der soeben erstellten Kopie der Datenbank Forum<APP> Vorschläge entsprechend den Einstellungen der alten Version der Vorschläge für Forum<APP> an.

    Mit Hilfe des IBM Domino Administrators und der Funktion Zugriffskontrolle > Kopieren  können Sie die komplette Zugriffskontrollliste der alten Version der Vorschläge in die Zwischenablage kopieren und mittels der Funktion Zugriffskontrolle > Einfügen auf die neue Version der Vorschläge übertragen.

    Empfohlener Zugriff

    Nachfolgende wird der empfohlene Zugriff auf die Vorschlags/Katalog Datenbank dargestellt.

    Server oder Servergruppe = Manager
    Administratorengruppe und BankSigner = Manager
    Default = Leser
    Anonymous = kein Zugriff


    Erweiterte Zugriffskontrollliste Vorschläge/Kataloge

    Öffnen Sie den Bereich Erweitert der Zugriffskontrollliste und setzen Sie den Wert für „Max. Internetnamens- und Kennwortzugriff“ auf Leser.

    Abbildung: Anpassung erweiterte Zugriffskontrollliste
  3. Vorschläge verknüpfen

    Die folgenden Einstellungen können nur durch technische Administratoren durchgeführt werden.

    Wählen Sie den Speicherort der zuvor auf den Server kopierten Vorschläge-Datenbank für die Anwendung.

    Der Servername muss nur angegeben werden, sofern dieser vom Server des FORUM Backends abweicht.

    Anstelle des Datenbankpfades können Sie alternativ auch die Replika-ID der jeweiligen Domino Datenbank angeben.

    Beachten Sie bei der Angabe des Datenbankpfades, dass dieser nicht mit einem Schrägstrich (/) oder Backslash (\) beginnen darf.

    Abbildung: Verknüpfung Vorschläge

    Betätigen Sie bitte jeweils das Häkchensymbol rechts unterhalb der Eingabefelder, um die Werte zu übernehmen.

  4. Reset der Anwendung

    Sofern Sie eine Vorschläge-Datenbank neu hinterlegt haben, klappen Sie bitte den Abschnitt Wartung im oberen Bereich der Konfiguration auf.

    Abbildung: Informationen zur Speichernutzung

    Betätigen Sie nun die Schaltfläche Reset. Die Vorschläge stehen nun in der Anwendung zur Verfügung.

    Abbildung: Wartung im Konfigrationsdokument

    Informationen zur Speichernutzung erhalten Sie die Schaltfläche (Info).

  5. Bitte informieren Sie die betreffende Fachabteilung, dass in der jeweiligen Anwendung neue Vorschläge für die Bearbeitung zur Verfügung stehen.

Java

Zum Einspielen neuer Vorschläge bzw. für die Aktualisierung bestehender Vorschläge gehen Sie bitte wie folgt vor:

Öffnen Sie in der Jeweiligen Anwendung unter Verwaltung  den Bereich Vorschläge 

Abbildung: Einstieg Vorschläge Beispiel ForumISM

Ziehen Sie das an Sie übermittelte ZIP Archiv mit den Vorschlägen via Drag'n'Drop(1) oder durch Auswahl aus den Dateisystem(2) in die Anwendung.

Abbildung: Import Vorschläge

Warten Sie, während die neuen Vorschläge eingespielt werden.

Bearbeiten der neuen Vorschläge

Nachdem die technischen Voraussetzungen erfüllt sind, werden die neuen Vorschläge auf Wunsch in den Produktivbereich übernommen.

Hinweis zu aktuellen Inhalten für die Datenbank

Nach dem Hinterlegen der aktuellen Vorschlagsdatenbanken in der Konfiguration der Anwendung erhalten Sie auf der Startseite den Hinweis, dass es aktuelle Inhalte in der Vorschlagsdatenbank gibt. In dem nachfolgendem Beispiel sind sind 91 neue Vorschläge hinzugekommen und in der Vorgängerversion der Vorschläge gibt es 133 Änderungen. Den Status der Vorschlagsdatenbank und deren Inhalte können Sie über die Aktivierung des Links (1) einsehen.

Abbildung: Hinweis zu aktuellen Inhalten in der Vorschlagsdatenbank

Über die Schaltfläche X (2) kann die Meldung ausgeblendet werden. Sie bekommen eine Hinweismeldung, dass die Benachrichtigung bis zum nächsten Vorschlagsrelease ausgeblendet wird. Alle Änderungsinformationen sind weiterhin über das Menü Verwaltung > Vorschläge erreichbar.

Abbildung: Hinweismeldung zum Ausblenden der Vorschlagsänderungen

Zu der aktuellen Vorschlagsdatenbank gelangen Sie auch über das Menü Verwaltung und Vorschläge. Die aktuelle Vorschlagsdatenbank ist direkt über den entsprechenden Link einsehbar

Abbildung: Vorschlagsdatenbank über die Verwaltung

Über den Vorschlagsbereich ist der Hinweis auch wieder aktivierbar, damit der Hinweis auf der Startseite wieder einzusehen ist.

Abbildung: Aktivierung der Startseitenbenachrichtigung

Vorschlagsstatus

Auf dieser Seite können Sie zur Vorschlagsversion die Beschreibung, die Übersicht der neuen Vorschläge und der geänderten bzw. nicht verwendeten Vorschläge einsehen. Unter der Titelleiste wird Ihnen die Versionsnummer und das Releasedatum angezeigt (1). Über die Dreiecke können die einzelnen Bereiche geöffnet und geschlossen werden (2). Über die Schaltfläche ? Hinweise zu den Vorschlägen (3) gelangen Sie in das Handbuch zur Anpassung der Konfiguration.

Abbildung: Vorschlagsstatus

Beschreibung

Auflistung aller erschienen Vorschlagsversionen und deren Releasedatum mit Nennung der wichtigsten Änderungen.

Abbildung: Vorschlagsstatus - Beschreibung

Meine geänderten Vorschläge

Vorschläge zu Objekten, welche in meiner Verantwortung liegen, können über die Schaltfläche Meine geänderten Vorschläge direkt aus der Startseite geöffnet werden.

Abbildung: Ansicht Meine geänderten Vorschläge

Abbildung: Übersicht zum Vorschlagsstatus und Hinweis auf Meine geänderten Vorschläge

Die geänderten Vorschläge können nun wie gewohnt einzeln, als Massenübernahme sowie als Massenlöschung übernommen werden.

Verantwortliche benachrichtigen

Verantwortliche für Dokumente mit geänderten Vorschlägen können nun aus der Übersicht des Vorschlagsstatus über die Schaltfläche Benachrichtigung versenden heraus benachrichtigt werden. Unter Details, welche Sie über das Dreieckssymbol öffnen können, werden Ihnen die Empfänger der Benachrichtigungen aufgelistet.

Abbildung: Benachrichtigung der Verantwortlichen zu geänderten Vorschlägen

Vorschläge löschen (Java Plattforum)

In diesem Bereich haben Sie die Möglichkeit der Löschung von nicht mehr verwendeten Vorschlagdatenbanken. Relevant beispielsweise, wenn Sie Vorschlagsdatenbanken wie ISO oder BSI getestet und sich dann doch im Haus gegen die Umsetzung entschieden haben. Während Sie in der Notes-Version die Datenbank einfach aus der Konfiguration entfernen können, ist dies in der Java-Version über diese Funktion möglich. Diese Vorschläge werden damit nicht mehr für Mitarbeiter zur Auswahl angeboten.

Der Aufruf der Funktion ist nur für Anwendungsmanager aus der Ansicht Verwaltung → Vorschläge innerhalb der einzelnen Standards möglich.

Die Vorschläge werden durch die Aktion physisch aus der Datenbank gelöscht. Bereits bestehende Verknüpfungen zwischen Vorschlägen und übernommenen Produktivobjekten bleiben jedoch unverändert erhalten

In der Übersicht der Vorschläge bleibt der Standard weiter angezeigt. Die Vorschläge werden aber nicht mehr auf Dokumentebene als Vorschlag angeboten.

Abbildung: Löschung von nicht verwendeten Vorschlagsdatenbanken

Neue Vorschläge

Hier werden kategorisiert alle neuen Vorschläge und deren Bezeichnung aufgelistet. Die jeweiligen Vorschläge können direkt aufgerufen (1) werden, um die Inhalte des Vorschlages einzusehen. Im Bereich rechts unterhalb der Seitenüberschrift stehen verschiedene Möglichkeiten für die Bearbeitung der Listenansicht zur Auswahl (2).

Abbildung: Vorschlagsstatus - Neue Vorschläge

Eine Übernahme eines neuen Vorschlages erfolgt wie gewohnt über die Schaltfläche Vorschlag übernehmen.

Abbildung: Neuen Vorschlag übernehmen

Geänderte Vorschläge, verwendet

Hier werden kategorisiert alle geänderten und verwendeten Vorschläge und deren Bezeichnung aufgelistet. Die jeweiligen Vorschläge können direkt aufgerufen (1) werden, um die Inhalte des Vorschlages einzusehen und zu vergleichen. Im Bereich rechts unterhalb der Seitenüberschrift stehen verschiedene Möglichkeiten für die Bearbeitung der Listenansicht zur Auswahl (2).

Abbildung: Vorschlagsstatus - Geänderte Vorschläge, verwendet

Ansicht zur Veränderung

Über die Verlinkung des jeweiligen Vorschlages gelangen Sie direkt zum gewählten Vorschlag. Sie bekommen im oberen Teil der Maske den Hinweis, dass eine Änderung vorliegt. Durch Anklicken der Schaltfläche (Änderung prüfen)(1) gelangen Sie zur Vergleichsansicht. Über die Schaltfläche Schließenwird die Ansicht geschlossen und Sie gelangen zurück zu Übersicht. Durch Aktivieren der Schaltfläche Übernommene Version (3) gelangen Sie zum gewähltem Objekt in dem produktiven Teil der Anwendung.

Abbildung: Vorschlagsstatus - Geänderte Vorschläge, verwendet - Hinweis auf Änderungen

Nach Aktivierung der Schaltfläche Übernommene Version befinden Sie sich im produktiven Teil der Anwendung ebenfalls den Hinweis zur Aktualisierung des Vorschlagsdokumentes. Durch Anklicken der Schaltfläche (Änderung prüfen)(1) gelangen Sie auch hier zur Vergleichsansicht.

Abbildung: Hinweis zur Aktualisierung des Vorschlages

Die Ansicht zur Veränderung - der Vergleich

In der Vergleichsansicht bekommen Sie die Änderung farblich hervorgehoben, auf der linken Seite sehen Sie ihr Produktivdokument und auf der rechten Seite das Vorschlagsdokument. Über die Schaltfläche Änderung ignorieren wird das Vorschlagsupdate in diesem Release ignoriert und der Vorschlag für dieses Objekt als „bearbeitet“ gewertet.
Möchten Sie die Änderungen übernehmen, aktualisieren Sie bitte die Schaltfläche Inhalte aktualisieren. Sie werden im nächsten Schritt gefragt, ob die gewählten Bereiche bzw. Felder aktualisiert werden sollen.

Ebenso kann die Struktur aktualisiert werden. Bitte beachte Sie, dass hierbei ggf. auch neue Unterobjekte aus dem Vorschlagsupdate übernommen werden können.

 

Abbildung: Aktualisierung und Inhaltsübernahme eines Vorschlages

Abgleich zur Übernahme von R1 Risiken in ForumOSM oder Sicherheitskonzepte in ForumISM

Für die Übernahme von Aktualisierungen der R1-Risiken der Rechenzentrale rufen Sie bitte die entsprechende Leistung auf. In der Einzelansicht der Leistung gehen Sie bitte über den Menüpunkt Extras auf den Abgleich mit Vorschlag.

Auf der linken Seite sehen Sie ihr Produktivdokument und auf der rechten Seite das Vorschlagsdokument. Über die Schaltfläche Inhalte aktualisieren kann eine Aktualisierung begonnen werden. Sie gelangen in die Auswahlmaske der zu aktualisierenden Risiken. Wählen Sie bitte die entsprechenden Risiken und aktualisieren die gewählten Objekte über die Schaltfläche Inhalte aktualisieren.

Abbildung: Ansicht Inhalte aktualisieren

Werden im Vorschlag weitere Inhalte zur Aktualisierung angeboten, können diese auch über separate Auswahl übernommen werden.

Ebenso kann die Struktur aktualisiert werden. Bitte beachten Sie, dass hierbei ggf. auch neue Unterobjekte aus dem Vorschlagsupdate übernommen werden.


Abbildung: Aktualisierung des Anhanges durch ein Vorschlagsupdate

Geänderte Vorschläge, nicht verwendet

Hier werden kategorisiert alle geänderten Vorschläge und deren Bezeichnung aufgelistet, welche in der Anwendung vor dem Vorschlagsupdate vorhanden waren, aber noch nicht in die Produktivversion übernommen bzw. verwendet worden.

Die jeweiligen Vorschläge können direkt aufgerufen (1) werden, um die Inhalte des Vorschlages einzusehen. Im Bereich rechts unterhalb der Seitenüberschrift stehen verschiedene Möglichkeiten für die Bearbeitung der Listenansicht zur Auswahl (2).

Abbildung: Vorschlagsstatus - Geänderte Vorschläge, nicht verwendet

Eine Übernahme eines geänderten und nicht verwendeten Vorschlages erfolgt wie gewohnt über die Schaltfläche Vorschlag übernehmen.

Abbildung: Geänderten und nicht verwendeten Vorschlag übernehmen

Archivierte Vorschläge aus dem Katalog entfernen.

Bereits übernommene Vorschläge sind im aktuellen Katalog nicht mehr vorhanden und müssen entfernt werden. In der Vorschlagsübersicht bekommen Sie den Hinweis zu archivierten Vorschlägen bereits rot markiert angezeigt.

In der Einzelansicht des betreffenden Objektes können Sie über die Schaltfläche Änderungen prüfen in die Vergleichsansicht gelangen.

Abbildung: Ansicht archivierter Vorschläge in der Übersicht der Änderungen

Diese Information bekommen Sie in der Vergleichsansicht mit dem Hinweis entfallen (1) angezeigt. Bitte übernehmen Sie diese Information über die Schaltfläche Inhalte aktualisieren. . ..

Abbildung: Archivierte Vorschläge aus dem Katalog

Durch die Aktivierung der Schaltfläche Inhalte aktualisieren bekommen Sie den Hinweis zur Aktualisierung angezeigt. Die Checkbox zum Aktualisieren der Struktur(1) des Objekts im Produktivbereich ist bereits vorbelegt. Bitte legen Sie nun über die Checkbox (2) fest, ob das übernommene Objekt ebenfalls durch die Aktualisierung gelöscht werden soll.

Abbildung: Hinweis zum Löschen des Objekts aus dem Produktivbereich

Soll das Objekt im Produktivbereich erhalten bleiben, deaktivieren Sie bitte die Checkbox Objekt im Produktivbereich löschen und bestätigen Sie den Vorgang durch die Schaltfläche Inhalte aktualisieren . Das Objekt bleibt im Produktivbereich erhalten und wird mit dem Hinweis Nicht mehr in Quelle vorhanden versehen.

Abbildung: Hinweis „Nicht mehr in Quelle vorhanden“

Verknüpfungen mit Vorschlägen

Durch aktualisierte Vorschläge ist es möglich, dass neue Objekte in die Vorschläge aufgenommen wurden, die so oder ähnlich schon von den Nutzern im Produktivbereich angelegt wurden. Um diese Objekte mit den Vorschlägen zu verknüpfen, kann im Vorschlagsbereich in der Einzelansicht eines Objektes die Schaltfläche „Verknüpfen“ genutzt werden.

Abbildung: Verknüpfen eines Vorschlages mit einem egenen Dokument

Falls für das Objekt noch kein Inhalte aus dem neu verknüpften Vorschlag festgelegt wurde und ein entsprechender Wert in der Vorschlagsdatenbank existiert, so kann dieser über den Menüpunkt Extras und Abgleich mit Vorschlag (siehe Abgleich zur Übernahme von R1 Risiken) übernommen werden. Für spätere Updates der Vorschläge ist die Verknüpfung bereits hergestellt und muss nicht nochmals bearbeitet werden.

Lösen der Verknüpfungen zu den Vorschlägen

Ist ein Objekt mit einem Vorschlag verknüpft, kann diese Verknüpfung nachträglich wieder gelöst werden. Wechseln Sie dazu über die Einzelansicht des Objektes über die Schaltfläche Vorschlag anzeigen in den Vorschlagsmodus und löschen die Verknüpfung über die Schaltfläche.Verknüpfung lösen.

Abbildung: Lösen der Verknüpfungen zu den Vorschlägen

Aktualisierung von Checklisten nach Vorschlagsupdate ab Version 2022-03

Für Checklisten, welche durch ein Vorschlagsupdate aktualisiert wurde, besteht nun eine Funktionalität zur Aktualisierung der betroffenen Fragen unter Beibehaltung bisheriger Antworten. In der betreffenden Ansicht bekommen Sie an der Checkliste den Hinweis zur Bearbeitung angezeigt. Das nachfolgende Beispiel zeigt Ihnen eine Bearbeitung einer Checkliste zur Klassifizierung einer Leistung in ForumOSM auf.

Abbildung: Aktualisierung von Checklisten nach Vorschlagsupdate

Im Bearbeitungsstand werden die Änderungen über die Schaltfläche Änderungen anzeigen deutlich hervorgehoben.

Abbildung: Änderungen anzeigen lassen

Neue Fragen in der Checkliste werden im grünen Rahmen sowie dem Hinweise „Diese Frage ist neu.“ angezeigt.

Abbildung: Anzeige neuer Fragen

Geänderte Fragen in der Checkliste werden im blauen Rahmen sowie dem Hinweise „Diese Frage wurde geändert.“ angezeigt. Bitte prüfen Sie, ob die getroffene Einschätzungen und die hinterlegte Bemerkung zur geänderten Frage noch passend sind. Über die Schaltfläche Bestätigen können Sie die Bearbeitung dieser Frage abschließen.

Abbildung: Anzeige geänderter Fragen

Wurden alle Änderungen und Neuerungen in der Checkliste bearbeitet, bestätigen Sie die Arbeit bitte abschließend über die Schaltfläche Aktualisierung abschließen am Ende der jeweiligen Checkliste.

Abbildung: Aktualisierung abschließen
Aktualisierung der Anwendung
HCL Domino

Die nachfolgenden Hinweise beziehen sich ausschließlich auf die IBM/HCL Domino Plattform.

ACHTUNG: Sofern der IBM Domino Server Teil eines Clusters ist, beachten Sie bitte unbedingt folgende Hinweise:

  • Die Datenbanken (Frontend und Backend) können ohne Einschränkungen per Cluster-Replikation repliziert werden.
  • Die HTTP-Task darf nur auf einem Server des Clusters für die Webanwendung genutzt werden, d.h. es muss sichergestellt werden, dass alle Anwender der Webanwendung auf denselben physischen Server zugreifen.
  • Wird dieser Umstand nicht beachtet, führt dies unweigerlich zu irreparablen Dateninkonsistenzen.
  • Aus diesem Grunde ist auch die Nutzung eines Clusters zur Lastverteilung der Anwendung nicht möglich.

Die Aktualisierung kann direkt auf jeder beliebigen Version der ForumSuite ohne weitere Zwischenschritte ausgeführt werden.

In der nachfolgenden Anleitung werden die folgenden Platzhalter verwendet:

  • <x.y.z.> .. Platzhalter für die aktuelle Versionsnummer

Schablone vorbereiten

Bitte entpacken Sie das Updatearchiv von Forum<APP> zunächst ihr ein lokales Verzeichnis.
Kopieren Sie anschließend die Datenbankschablonen forum_frontend_X.Y.Z.ntf und ggf. forum_backend_X.Y.Z.ntf in das lokale Datenverzeichnis Ihres Notes-Clients.

!! Versuchen Sie es einfach mal mit der Eingabe der Umgebungsvariable %notesdata% in der Adresszeile des Windows Explorers. !!

Vorgehensweise

Für die nachfolgenden Tätigkeiten wird der Domino Administrator Client benötigt.

Beenden des HTTP-Task

Für die Anwendung des Updates ist es erforderlich, dass die HTTP-Task des Domino Servers zuvor beendet wird.

Bitte beachten Sie, dass durch ein Beenden der HTTP-Task eventuell geöffnete Sitzungen von Nutzern der FORUM Anwendungen und ggf. anderen Web-Anwendungen ohne Rückfrage geschlossen werden.

Führen Sie das Update daher zu einem geeigneten Zeitpunkt ohne Nutzeraktivität durch.

Sie können sich aktive Sitzungen im Domino Administrator unter „Server > Status > Internet Users“ oder über die Serverkonsole über den Befehl show inetusers anzeigen lassen.

Beenden Sie die HTTP-Task des Dominoservers über die Ansicht „Server > Status > Server Tasks“ (Rechtsklick auf HTTP Server) oder durch Aufrufen des folgenden Befehls an der Serverkonsole:

HTTP Task stoppen

BASH
tell http quit

Abbildung: HCL Domino HTTP stoppen

Ersetzen der Gestaltung

Die Gestaltung muss durch einen Benutzer mit Manager-Rechten und aktivierter Datenbankrolle [ADMIN] aktualisiert werden.

Wechseln Sie im IBM Domino Administrator auf den Server, auf welchem die Anwendungen betrieben werden.

Abbildung: Serverauswahl

Navigieren Sie im Reiter Dateien zum Ablageort Ihrer Anwendungen und ersetzten Sie die Gestaltung der Anwendungen. Markieren Sie hierzu die Anwendung, auf welcher ein Schablonenwechsel durchgeführt werden soll und starten Sie das Update über den Befehl „Datei > Anwendung > Schablone wechseln“.


Abbildung: Schablone wechseln

Wählen Sie den Schablonenserver lokal (bzw. ihren Server, sofern Sie mit der Server ID signiert haben) und die Schablone FORUM Frontend X.Y.Z oder FORUM Backend X.Y.Z aus der Auswahlliste:

Abbildung: Schablonenauswahl

Bestätigen Sie den Dialog mit Ersetzen.

!! Bitte achten Sie drauf, dass der Haken "Formeln und LotusScript verbergen" nicht gesetzt ist !!

Beobachten Sie in der Fußzeile des Domino Administrator Clients bitte den Verlauf des Schablonenwechsel's.

Fahren Sie erst fort, wenn der Vorgang vollständig abgeschlossen wurde.

Wiederholen Sie die Schritte bitte für die jeweils andere Datenbank.

Datenbanken signieren

Hinweismeldung zum Signieren mit einer vertrauenswürdigen Notes-ID

Sofern die Frontend- oder Backend-Datenbank noch nicht korrekt signiert wurde, wird in der Notes-Maske ein entsprechender Hinweis angezeigt.

Abbildung: Signaturfehler

Signieren Sie die auf Datenbanken forum_frontend.nsf und forum_backend.nsf mit einer vertrauenswürdigen Notes-ID. Hierzu wird entweder die ID eines speziellen Freigabe-Nutzers, eines Administrators oder die ID des Servers genutzt.

Die zur Freigabe verwendete Notes ID muss auf dem Domino Server die Berechtigung „Agenten oder XPages signieren, die im Namen des Aufrufers ausgeführt werden“ (engl.:„Sign agents or XPages to run on behalf of the invoker“) haben. Sie können dies im Reiter Sicherheit des Serverdokuments überprüfen.

Falls Sie die Anwendung mit der Server ID signieren möchten, kopieren Sie zunächst die Schablone forum_frontend_X.Y.Z.ntf und ggf. forum_backend_X.Y.Z.ntf über den IBM Notes Client auf Ihren Server. Fügen Sie hierzu die Datenbankschablone forum_frontend_X.Y.Z.ntf und ggfls. forum_backend_X.Y.Z.ntf zu Ihrem Lotus Notes Arbeitsbereich hinzu und erstellen Sie anschließend mit Hilfe der Funktion Datei > Anwendung  > Neue Kopie die Kopie auf dem Server.

Signieren Sie die Schablone danach über den Domino Administrator mit der Server ID wie weiter unten beschrieben.

!! Übertragen Sie die Schablone nicht direkt über das Dateisystem auf den Domino Server, da diese hierbei beschädigt werden kann !!

Wählen Sie im Dialog ID des aktiven Benutzers mit der die Signierung durchgeführt werden soll, deaktivieren Sie die Option „Nur vorhandene Signaturen aktualisieren“ und bestätigen Sie mit OK.

Abbildung: Anwendung signieren

Beobachten Sie in der Fußzeile des Domino Administrator Clients bitte den Verlauf des Signier-Vorganges.

Fahren Sie erst fort, wenn der Vorgang vollständig abgeschlossen wurde (die Anzeige 100% muss verschwunden sein).

Starten des HTTP Task

Starten Sie den HTTP-Task des Dominoservers über die Ansicht „Server > Status > Server Tasks“ (Rechtsklick auf HTTP Server) oder durch Aufrufen des folgenden Befehls an der Serverkonsole:

HTTP Task starten

BASH
load http

Abbildung: HCL Domino HTTP Start


Aktualisierung beendet

Die Aktualisierung der Gestaltung ist damit abgeschlossen.

Öffnen Sie die ForumSuite im Browser.
Starten Sie nacheinander die bei Ihnen aktiven Anwendungen, betätigen Sie Update starten und warten das Ende des vollautomatischen Vorgangs ab.
Sie werden anschließend auf die Startseite der jeweiligen Anwendung weitergeleitet.

Java

Windows

In der nachfolgenden Anleitung werden die folgenden Platzhalter verwendet:

  • <JJJJ-MM> .. Platzhalter für die aktuelle Versionsnummer
  •  <*> .. Wildcard für beliebige Zeichen

Die Aktualisierung kann direkt auf jeder beliebigen Version der ForumSuite ohne weitere Zwischenschritte ausgeführt werden.

Ab Version 2023-10 ändert sich der Name des Parameters für die Hinterlegung der Logdatei.

Änderung in der Datei config\application.properties

TEXT
#von
logging.file
#zu
logging.file.name

Führen Sie bitte folgende Schritte in Abhängigkeit des bei Ihnen eingesetzten Betriebssystems durch.

Abbildung: Aufruf Dienste-Manager

Löschen Sie die alte Programm Datei (FORUM_Suite_<*>.jar) im Verzeichnis der Anwendung auf dem Server.

Abbildung: altes JAR löschen

Kopieren Sie die neue Programm Datei aus dem heruntergeladenen Archiv in das Verzeichnis der Anwendung auf dem Server.

Abbildung: Dienst starten

Linux

Dienst herunterfahren

BASH
systemctl stop forumsuite.service

Löschen Sie die alte Programm Datei (FORUM_Suite_<*>.jar) im Serververzeichnis.

Kopieren Sie die neue Programm Datei aus dem heruntergeladenen Archiv in das Serververzeichnis.

Dienst starten

BASH
systemctl start forumsuite.service

Öffnen Sie die ForumSuite im Browser.
Starten Sie nacheinander die bei Ihnen aktiven Anwendungen, betätigen Sie Update starten und warten das Ende des vollautomatischen Vorgangs ab.
Sie werden anschließend auf die Startseite der jeweiligen Anwendung weitergeleitet.















JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.